Jump to content

Water pump


Recommended Posts

Hi, I just parked at my first boondocking site. Filled my fresh water tank, and turned on the water pump. Heard no sound. It’s not pressurizing the tank. No water flows from any faucet. What am I doing wrong?  Or, Heaven forbid, is the pump broken?  I’ve never used pump before. 
HELP!

Charlie. 

Charlie

Hull 734 - 2021 Oliver Elite II

pulled by F-150

Out of Florida

Link to comment
Share on other sites

  • Moderators

Charlie - 

When you turn on the water pump switch does the little light on the switch glow green?

How did you fill the fresh water tank?  Have you looked under the curbside bed to make sure that your valves are in the correct position?

What year and model Ollie do you own?

Have you checked the water pump fuse?

That's a start......

Bill

  • Like 1

2017 Ford F150 Lariat 3.5EB FX4 Max Towing 2016 Oliver Elite II - Hull #117 "Twist"

Link to comment
Share on other sites

I used the street side fresh water inlet. The green light is on. The first valve on left lower side is open. It seems that no water is being drawn from the tank. No sound. Is there a circuit breaker for the pump somewhere?

 

citrusbreeze

Charlie

Hull 734 - 2021 Oliver Elite II

pulled by F-150

Out of Florida

Link to comment
Share on other sites

  • Moderators
19 minutes ago, Citrus breeze said:

Is there a circuit breaker for the pump somewhere?

My 2017 LE2 water pump has a circuit breaker in the attic.  I do not know if that applies to your Ollie or not.

Mossey

  • Like 1

Mike and Krunch   Lutz, FL  
2017 LEII #193 “the dog house”

 

 

Link to comment
Share on other sites

  • Moderators

No guarantee - but - if the green light is "on" at the switch then it is likely that there is power getting to the pump.

Have you checked the wire connections at the pump?

Have you tried the water pump switch in the bathroom/shower AND the one in the main cabin?

 

  • Like 3

2017 Ford F150 Lariat 3.5EB FX4 Max Towing 2016 Oliver Elite II - Hull #117 "Twist"

Link to comment
Share on other sites

  • Moderators

Our water pump quit working once.  When I checked it I noticed that there was a wire lose that goes to the pump.  On mine, there are two red wires that connect to the pump.  Make sure they are both still connected.  They can work lose if you are on bumpy roads.  Mike

  • Thanks 1
  • Like 3

Texas Hill Country | Elite II #135 | Ram 2500 6.7L

ALAZARCACOFLGAIDILKSKYLAMDMSMOMTNENVNMNYNCNDOHOKSCSDTNTXUTVAWVWYsm.jpgALAZARCACOCTDEFLGAIDILINIAKSKYLAMEMDMAMS

Link to comment
Share on other sites

  • Moderators

It's really helpful if you complete year and hull number in your profile, and signature. 

Our 2008 has a couple switches to turn off the pump. One by the door.

Your pump may need a prime.

  • Like 4

2008 Ram 1500 4 × 4

2008 Oliver Elite, Hull #12

 

 

Link to comment
Share on other sites

  • Moderators

Have you tried just turning on a faucet? Even with the pump on, the water will not run if it doesn’t sense a change in water pressure. 

  • Like 5

Steve, Tali and the dogs: Reacher and Rocky plus our beloved Storm, Maggie and Lucy (all waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD SRW Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

Pump failures are not uncommon, and if yours is defective from the factory, the failure could be right away. Mine quit unexpectedly but it took five years…. Do you have a volt meter (VOM tester) and do you know how to do very basic electrical troubleshooting? If not, maybe this would be a good starting point for you to learn how.

John Davies

Spokane WA

  • Like 1

"Mouse":  2017 Legacy Elite II NARV (Not An RV) Two Beds, Hull Number 218, See my HOW TO threads: https://olivertraveltrailers.com/topic/john-e-davies-how-to-threads-and-tech-articles-links/

Tow Vehicle: 2013 Land Cruiser 200, 33" LT tires, airbags, Safari snorkel.

Link to comment
Share on other sites

Thanks Everyone!

I called Jason at Oliver. He returned the call quite promptly, and talked me through various things to check. 
Turned out I had to go to the water pump itself under the curb side bed to check the wires. There are two little red wires that attach to the underside of the pump, near you as you look. One of them was not connected at all!  Three screws had to be removed to be able to reattach the wire once attached…Everything worked. Surprise!

Thanks for all the feedback. 

Citrusbreeze

Charlie

 

  • Like 5

Charlie

Hull 734 - 2021 Oliver Elite II

pulled by F-150

Out of Florida

Link to comment
Share on other sites

8 minutes ago, Citrus breeze said:

Thanks Everyone!

I called Jason at Oliver. He returned the call quite promptly, and talked me through various things to check. 
Turned out I had to go to the water pump itself under the curb side bed to check the wires. There are two little red wires that attach to the underside of the pump, near you as you look. One of them was not connected at all!  Three screws had to be removed to be able to reattach the wire once attached…Everything worked. Surprise!

Thanks for all the feedback. 

Citrusbreeze

Charlie

 

Glad Jason got you squared away. 

Happy Camping!
 

  • Like 2

0EED8E3B-D84E-4F0D-B52F-5E473FD3F2B4.jpeg.594e912d889377ce9a64a2f5c88ade83.jpeg

2020 OLEII - Hull #634   TV -2021 F 350 6.7 liter Diesel Lariat Ultimate “Tremor”

 

Link to comment
Share on other sites

  • Moderators
On 6/6/2022 at 5:34 PM, Mike and Carol said:

Our water pump quit working once.  When I checked it I noticed that there was a wire lose that goes to the pump.  On mine, there are two red wires that connect to the pump.  Make sure they are both still connected.  They can work lose if you are on bumpy roads.  Mike

 

10 hours ago, Citrus breeze said:

Thanks Everyone!

I called Jason at Oliver. He returned the call quite promptly, and talked me through various things to check. 
Turned out I had to go to the water pump itself under the curb side bed to check the wires. There are two little red wires that attach to the underside of the pump, near you as you look. One of them was not connected at all!  Three screws had to be removed to be able to reattach the wire once attached…Everything worked. Surprise!

Thanks for all the feedback. 

Citrusbreeze

Charlie

 

The red wires do fall off.

  • Like 3

Texas Hill Country | Elite II #135 | Ram 2500 6.7L

ALAZARCACOFLGAIDILKSKYLAMDMSMOMTNENVNMNYNCNDOHOKSCSDTNTXUTVAWVWYsm.jpgALAZARCACOCTDEFLGAIDILINIAKSKYLAMEMDMAMS

Link to comment
Share on other sites

  • Moderators
On 6/6/2022 at 5:59 PM, topgun2 said:

Have you checked the wire connections at the pump?

Indeed they do.

Bill

  • Like 2

2017 Ford F150 Lariat 3.5EB FX4 Max Towing 2016 Oliver Elite II - Hull #117 "Twist"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...