Jump to content

Backup Camera stopped working


Ken_Judy

Recommended Posts

Hi All,  My backup camera stopped working and the head unit cannot connect wirelessly even if it is within inches of the camera.  Of course the power is on to the camera.  My question is has anyone had this problem and how do i check if power is getting to the camera.  Also,  on my 2018 Hull #381 there doesn't seem to be a 12v fuse labled backup camera and the schematic doesn't show which one it would be.  I just thought I would ask here before tearing into everything.  Thanks

Link to comment
Share on other sites

  • Moderators

Try this - 

turn the power off for both the monitor and the camera.  

Assuming that you have verified that the camera is receiving power - turn it back on

while looking at the monitor, turn it back on - does it give instructions as to "re-pairing" it with the camera?

If yes, then do what it says.

Good luck!

Bill

  • Like 3

2023 Ford F150 Lariat 3.5EB FX4 Max Towing, Max Payload, 2016 Oliver Elite II - Hull #117 "Twist"

Link to comment
Share on other sites

  • Moderator+
On 10/16/2023 at 8:08 PM, Ken_Judy said:

Hi All,  My backup camera stopped working and the head unit cannot connect wirelessly even if it is within inches of the camera.  Of course the power is on to the camera.  My question is has anyone had this problem and how do i check if power is getting to the camera.  Also,  on my 2018 Hull #381 there doesn't seem to be a 12v fuse labled backup camera and the schematic doesn't show which one it would be.  I just thought I would ask here before tearing into everything.  Thanks

You did not say which camera is installed on your trailer. IF there is a fuse it will be an inline one in the power cord hidden behind the white reflectix insulation glued inside the attic cabinet. You'll have to pull it all down to find it. Put it back into place using spray contact cement. Use of this will probably set off your propane detector.

  • Like 4

Steve, Tali and our dog Rocky plus our beloved Storm, Maggie, Lucy and Reacher (all waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD SRW Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

Had the same problem.  Seems that tree branch ate my Furrion rear camera antenna.  

Worth a glance.

GJ

  • Like 2

TV:  2019 F-150 SuperCrew Lariat, 3.5L EcoBoost, Max Tow, FX-4, Rear Locker      OLLIE:  2018 OE2 Hull 342, Twin Bed.    OLLIE DIY’s: Timken Bearings, BB LiFePO4's, Victron 712 Smart, 350 Amp Master Switch, Houghton 3400, Victron Orion DC - DC, 3000-Watt Renogy Inverter, P.D. 60-amp Converter, Frig Dual Exhaust Fans, Kitchen Drawer Straps.    TV DIY’s:  2 5/16" Anderson System, Nitto recon’s, Firestone Rear Air Bags, Bilstein 5100’s, Mud Flaps & Weather Tech all, installed Ham Radio (WH6JPR).

  image.jpeg.9633acdfb75740f0fd358e1a5118f105.jpeg

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...