Jump to content
Sign in to follow this  
SeaDawg

Thermocouple on the cooktop burner

Recommended Posts

After nine years, finally had a problem with the SMEV cooktop. The bigger burner (of course) lit with a full, beautiful blue flame, but wouldn't stay lit. Not after multiple tries (with longer hold times, finally up to a thirty count.)

I cleaned the burner, and the cover, and the thermocouple pin. The igniter ceramic coated pin, for good measure. Still a no go. So, I figured, likely the thermocouple was bad. Making coffee, pancakes, and sausage on the little burner, for a group, was not a fun prospect.

I tried lighting again, looked at the position of the pin vs the flame, and thought the pin was out of the flame. I let everything cool, and applied moderate pressure to the pin with my thumb to get it back in the flame. Tried again.

Got my burner back! I'd probably bent the pin at some point cleaning the cooktop, over the last nine years. My thumb pressure probably moved it 1/64 to 1/32, but it was evidently enough.

Glad of it, as replacing the thermocouple requires disassembling the top... Plus a new thermocouple, which I did not have.

Sherry

  • Thanks 6

2008 Ram 1500 4 × 4

2008 Oliver Elite, Hull #12
 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...