Jump to content

Fantastic Vent Problems


Recommended Posts

Help needed from techies. Our exhaust fan suddenly died on us. It's the rain sensing Fantastic Vent. Yes the fuse is fine. I pulled the fan and see a white and a black wire coming out of the space between the shells and running to the fan. When I stick a voltmeter across these two wires I don't get any current flow. Does anybody know how the Oliver power runs to the fan? What is the connection on the circuit board as none of the fuses there seem blown either. Any help is appreciated.

 

Thanks,

Angler

Link to comment
Share on other sites

  • Moderators

Does your bathroom exhaust fan run? The same switch beside the entrance door feeds power to both fans (Ours is labeled Accessory.)

Steve, Tali and the dogs: Reacher, Lucy and Rocky plus our beloved Storm and Maggie (both waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

My advice is to call the company. Mine went out and that's what I did.

 

After I described my problems they sent me some kind of electrical device that filters out any signal interference from other electronic devices so that my remote control could work properly.

 

It was easy to install and I've had no problems since.

 

Doug

Link to comment
Share on other sites

ScubaRx,

 

Your answer was inspired. After removing all the plates, cups, glasses and other needed stuff in the slider above the microwave compartment, I found that a red wire marked "roof" had pulled loose from the "accessory" switch. Pushed it back on to the circuit board and the fans both work. I'm now in the process of fashioning a cover for the back of the switches to keep this from happening again. A follow up question for you please: in the bundle of wires that goes to the switches here, there is a yellow wire marked "ground" that doesn't attach to anything. It is equipped with a round shaped connector, not a flat one like the fan wire was. We don't have a microwave (almost exclusively use the Oliver for dry camping) and wonder if this wire ought to have home somewhere or is it orphaned due to our lack of microwave?

 

Doug,

 

I agree, the folks at Oliver are always helpful, but ScubaRx's answer beat the factory for time.

 

Thanks all,

 

Angler

Link to comment
Share on other sites

  • Moderators

Thanks for the kind words Angler. I'm currently at work so I won't be able to look at the panel until later. I know the wire you're talking about. I've spliced into it in the past to get a ground for some mods that I installed in that area. That said, I would have to assume mine is grounded somewhere, else my mods would not have worked. If I recall, my thought at the time was that the yellow wire was the ground for the panel itself.

Steve, Tali and the dogs: Reacher, Lucy and Rocky plus our beloved Storm and Maggie (both waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...