Jump to content

Recommended Posts

  • Moderators

I can turn my inverter on but not off. To turn it off I have to remove the remote on/off switch and on the back move the  switch from “disable ACC” to “enable” which turns it off. Then I can move it back to disable and can turn it back on, just not off.

 

When it is on, the on/off switch on the inverter itself won’t turn it off either. There are no error codes and when it is on everything works normally. Since we’re here at Quartzsite, I took my switch to another Oliver and it worked fine. I took the switch from the other Oliver and plugged it into my inverter and it would not turn it off either. So, I don’t think it is the remote switch, especially since the switch on the inverter doesn’t work either.

 

Is anyone else having this problem?  I’m going to call the support number at Xantrex tomorrow. I read through everything on their web site and they don’t address this issue. Mike

Fair Oaks Ranch, TX | 2016 Elite II #135 | 2020 Ram 2500 Laramie 6.7L Cummins Turbo Diesel

ALAZARCACOFLGAIDILKSKYLAMDMSMOMTNENVNMNYNCNDOHOKSCSDTNTXUTVAWVWYsm.jpg

 

Link to post
Share on other sites
  • 2 years later...

Mike did you ever figure this out?

I ask because I am having the opposite problem. I can turn the inverter off using the remote wall switch. but to turn it on I need to lift the bed and turn it on at the unit level. 

 

  • Like 1
Link to post
Share on other sites
  • Moderators
8 hours ago, Daecart said:

Mike did you ever figure this out?

I ask because I am having the opposite problem. I can turn the inverter off using the remote wall switch. but to turn it on I need to lift the bed and turn it on at the unit level. 

 

I called Xantrex (it’s been a couple of years or so) and they spent an hour or so on the phone troubleshooting various things that I can’t recall.  What finally did the trick was to simply power it down totally by disconnecting it from everything and letting it sit for a day.  When I hooked it back up all was well.  If you call their support number they are very willing to walk you through troubleshooting.  Hope this helps!  Mike

  • Like 2

Fair Oaks Ranch, TX | 2016 Elite II #135 | 2020 Ram 2500 Laramie 6.7L Cummins Turbo Diesel

ALAZARCACOFLGAIDILKSKYLAMDMSMOMTNENVNMNYNCNDOHOKSCSDTNTXUTVAWVWYsm.jpg

 

Link to post
Share on other sites
  • Moderators

I had a similar issue that turned out to be a faulty remote switch.  After discussing the issue with the rep at last year's Owner's Rally and trying a few of his suggestions I called, we talked about it briefly and then a week later a new switch arrived at my doorstep.  These switches are not terribly expensive (less than $30) and my unit is pushing the five year old mark, but, it was very nice of Xantrex to warranty the part anyway.  The install was extremely easy and now everything is back to normal.

Bill 

2017 Ford F150 Lariat 3.5EB FX4 Max Towing 2016 Oliver Elite II - Hull #117 "Twist"

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...