Jump to content

Truma CP Plus Control Panel error code

Recommended Posts

2023 Elite II with Truma A/C, Truma on-demand hot water heater and Furnace, Isotherm frig. Setting uo at campsite once shorepower was connected the Truma Control Panel showed Alert diamond in center at bottom control panel. When selected the code read W255 W. The manuals provided on flashdrive to not list this error code. A/C would not come on when selected. Anyone have full listing of error codes. I think it is associated with power rocker switch behind exterior access panel for on-demand water heater which we were instructed to turn OFF when preparing to leave for next camping location. Mike Griffin

  • Thanks 1
  • Like 1
Link to comment
Share on other sites

travel trailer units for sale
Find Oliver Inventory Travel Trailers for Sale
View Inventory

Welcome to the Oliver family and the forum! Steep learning curve those first few days using the Ollie. 

Just tested mine with the unit switch off and that is the code that popped up on the control panel when I tried to turn the water heater on inside. 

Not sure why they are saying to turn off the unit switch for travel. I would personally only turn this off for storage. 

  • Like 3

What's today?............. the most frequently asked question as a retiree 🙄

Chris and Stacie Neuhaus Greenfield, Indiana

2021 Ford F350 7.3L Tremor (Redzilla)

LE2 #1373 - Ordered 10/21/22 - Delivered 05/10/23

States Visited Map

Link to comment
Share on other sites

  • 7 months later...

Just took our factory delivery (a Great Experience…) & stayed at the Oliver campground to spend a night. The following morning, the CP-Panel had the triangle/! icon lite & the water heater icon/information was missing as well. The error code W255 W was displayed when scrolling/selecting the triangle / Icon… An initializing of ‘reset’ resulted in No change…still no water heater info on display.
The only ‘problem’ was the 3-position on/off/on switch on the water heater was in the ‘off’ position, so selecting ‘ON’ & then repeating the reset/initializing process restored the water info on the panel - ‘Problem Solved’

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...