Jump to content

Furrion DV1230 Bluetooth connection working


Recommended Posts

Have successfully connected to BT with my iPhone in the past, but now I cannot connect.  Furrion display states "LINK OKAY", but I still can't connect.

I have deleted the old connection on my iPhone and tried to reconnect but it just keeps searching for the connection.

Any tips and tricks will be appreciated.

Ellie Kelly

ALGAMANHNCPASCTNVAmed.jpg

2021 Elite 2, Twin Bed, Lithium & Solar, 3000W Inverter #880

2019 Ford F150, 3.5L V6 EcoBoost, 4x4 Supercab, Trailer Tow Package

Link to comment
Share on other sites

Make sure your spouse's phone, a laptop or another device is not connected. The message "LINK OKAY" likely means there is a connection, but perhaps not your source. When we've had this connectivity issue, this is generally the cause.

 

  • Like 3

Chris & John in Prescott, AZ | 2016 EII #113 | '01 Ram 2500 Cummins!

Link to comment
Share on other sites

  • Moderators

Another quick suggestion is to turn everything off - Furrion, phone, etc- and then try connecting again.

Bill

  • Like 1

2023 Ford F150 Lariat 3.5EB FX4 Max Towing, Max Payload, 2016 Oliver Elite II - Hull #117 "Twist"

Link to comment
Share on other sites

We have the same issue using our Furrion with multiple BT devices.  

We usually do a manual check in "Settings - Blue Tooth" to discover which device is connected when the Furrion displays the "LINK OK" message.  We've defaulted to agree we always use D's devices for the music source and my BT is simply selected to "OFF".  

Edited by MAX Burner
fixed a typo
  • Like 1

spacer.png

Art, Diane, Oscar & Magnus (double-Aaarrf!)

  • 2022 TUNDRA w/Airlift Load Lifter 5000 kit/2017 LE II; Hull #226 "Casablanca", 12VDC Starlink kit, 3x Battle Borns; Victron Cerbo GX, SmartShunt, MPPT Solar Controller, & DC-DC Charger; HAM call-sign:  W0ABX
Link to comment
Share on other sites

Thank you all for suggestions.  I called Furrion after nothing worked and they walked me through a hard reset of the system.  That solved the problem.

  • Like 3

ALGAMANHNCPASCTNVAmed.jpg

2021 Elite 2, Twin Bed, Lithium & Solar, 3000W Inverter #880

2019 Ford F150, 3.5L V6 EcoBoost, 4x4 Supercab, Trailer Tow Package

Link to comment
Share on other sites

59 minutes ago, The Loonies said:

I called Furrion after nothing worked and they walked me through a hard reset of the system.  That solved the problem.

Nice, how did you do the hard reset? 

2023 Elite II, Hull# 1386, Lithium Platinum Package (640AH, 400W Solar, 3000W Xantrex Inverter)
Truma water heater & AC

TV: 2024 Silverado 2500HD 6.6L 10-Speed Allison

Link to comment
Share on other sites

There is a small hole next to the USB port for RESET.  Insert a pin and hod for a few seconds, the Furrion wi reset.

Yes, prior Bluetooth connections wi be gone, but it is easy to reconnect.

  • Like 5

ALGAMANHNCPASCTNVAmed.jpg

2021 Elite 2, Twin Bed, Lithium & Solar, 3000W Inverter #880

2019 Ford F150, 3.5L V6 EcoBoost, 4x4 Supercab, Trailer Tow Package

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...