Jump to content

Generator power not going into trailer


Recommended Posts

Any ideas why my generator power isn’t showing up in the trailer despite being plugged in the same as always. 
 

The only thing that has happened since I last ran the generator last Winter is my water pump stopped working, so repair guy ran new positive line from switch to pump. 
 

could the repair guy have done something to prevent generator power to enter the trailer?

 

thank you 

2018 Elite


TV - Audi Q5 3.0 TDI

Link to comment
Share on other sites

25 minutes ago, DonnaDuane said:

Any ideas why my generator power isn’t showing up in the trailer despite being plugged in the same as always. 
 

The only thing that has happened since I last ran the generator last Winter is my water pump stopped working, so repair guy ran new positive line from switch to pump. 
 

could the repair guy have done something to prevent generator power to enter the trailer?

 

thank you 

Do you have your neutral ground plug - plugged into the generator?

  • Like 2

 

2020 OLEII - Hull #634 aka-  “XPLOR” 

2021 F350 6.7 liter Diesel Lariat Ultimate Tremor 

 

IMG_2879.jpeg

Link to comment
Share on other sites

  • Moderator+

There is a switch on the EMS display that will allow power (from any source) to bypass the EMS. You can feel reasonably confident that the power coming from your own generator is safe and switch the bypass on so you can at least get power while you're figuring this all out. I can't see any reason that what the RV repair guy did could have caused this. 

I assume you're using the front generator hook-up. There's a transfer switch (under the front dinette seat) that SHOULD activate once it senses power being applied to that port (you should hear a click from the contact points inside). If the transfer switch is bad that would be the problem.

  • Like 3

Steve, Tali and our dog Rocky plus our beloved Storm, Maggie, Lucy and Reacher (all waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD SRW Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

Yes. Using front generator/shore power hook up. Excuse my ignorance but where is the EMS display? When I look in the compartment there’s a little box with a led display and a switch. I’ve tried flipping the switch but nothing changed. The usual click when the system switches from battery to AC didn’t happen. 

2018 Elite


TV - Audi Q5 3.0 TDI

Link to comment
Share on other sites

43 minutes ago, skalywag said:

Are you using a Bonding Neutral plug with your generator? Sometimes referred to as an "Edison Plug"

A neutral bonding plug plugs in to one of the 120V receptacles on your generator.  It looks like the image below.  Your Oliver electrical system will not accept power from a generator without one:

 

image.thumb.jpeg.1e1c2a7bfcbbd1973ddf46c46a9de45e.jpeg

  • Thanks 1
  • Like 2

 

Hull #1291

Central Idaho

2022 Elite II

Tow Vehicle:  2019 Tundra Double Cab 4x4, 5.7L with tow package

ARCOIDNMOKORTNTXUTsm.jpg

Link to comment
Share on other sites

Yes. have been using a Bonding Neutral plug since I got it. I have been using the generator for power to the trailer for the past 5 winters, as that's when I use the Oly most. I take it skiing. I just learned from Service that I need to record the messages on the EMS LED when switched on. It displayed an error message and some other info.

I checked the circuit breaker panel for issues and found none.

 

Thank you for your suggestions and keep them coming if you know how to get this thing working again.

  • Like 2

2018 Elite


TV - Audi Q5 3.0 TDI

Link to comment
Share on other sites

12 minutes ago, DonnaDuane said:

Yes. have been using a Bonding Neutral plug since I got it. I have been using the generator for power to the trailer for the past 5 winters, as that's when I use the Oly most. I take it skiing. I just learned from Service that I need to record the messages on the EMS LED when switched on. It displayed an error message and some other info.

I checked the circuit breaker panel for issues and found none.

 

Thank you for your suggestions and keep them coming if you know how to get this thing working again.

Please post up what you learn from service. It will be invaluable feedback for everyone. I feel sure they will get you taken care of quickly.👍🏻😊
 

Patriot🇺🇸

 

  • Like 2

 

2020 OLEII - Hull #634 aka-  “XPLOR” 

2021 F350 6.7 liter Diesel Lariat Ultimate Tremor 

 

IMG_2879.jpeg

Link to comment
Share on other sites

  • Moderator+
9 hours ago, ChrisMI said:

I would try hooking the generator up to the main power input and check the gen switch/circuit breaker.

The transfer switch (gen switch, if that is what you're referring to) does not come into play if plugging the generator into the side port. But, if you plug it in there and it passes power to the coach it validates what I said above, the transfer switch is bad.

  • Like 2

Steve, Tali and our dog Rocky plus our beloved Storm, Maggie, Lucy and Reacher (all waiting at the Rainbow Bridge)

2008 Legacy Elite I - Outlaw Oliver, Hull #026 | 2014 Legacy Elite II - Outlaw Oliver, Hull #050 | 2022 Silverado High Country 3500HD SRW Diesel 4x4 

 

             801469912_StatesVisitedTaliandSteve08-23-2021-I.jpg.26814499292ab76ee55b889b69ad3ef0.jpg1226003278_StatesVisitedTaliandSteve08-23-2021-H.jpg.dc46129cb4967a7fd2531b16699e9e45.jpg

 

 

Link to comment
Share on other sites

Seems some of my posts are not showing up here. I posted the following last night to see if any of you know that this means.

When I run the generator the LED on the EMS switch lights up, so power is getting to that switch. However, still no power to trailer. When it's switched to the ON position, I get the following codes: 128, OA, 60H, E2, PE2 

Just spoke with Oliver. Here's what I learned. Those codes are saying either the Neutral Ground plug is faulty, or the surge protector is faulty, or the connection to the bypass switch is faulty. He recommended having an RV Tech check it out after trying a new Neutral Ground Plug.

Duane

IMG_1122.jpg

  • Like 1

2018 Elite


TV - Audi Q5 3.0 TDI

Link to comment
Share on other sites

@DonnaDuane here is a list of the EMS codes, looks like open ground! 
image.thumb.jpeg.01dafe112f5b2b49f82aec6baa1d4546.jpeg

this box should be under your rear dinette. 
 

Check out this thread, sounds like (might be) your ground bonding plug is faulty, so either get a replacement neutral ground bonding plug, or turn off the EMS and trust the generator. IF it’s a faulty ground bonding plug, a replacement bonding plug is not that expensive, that would be my go to.

Stupid question, did you check if the ground bonding plug is seated properly in your generator?

  • Like 3

2023 Elite II, Hull# 1386, Lithium Platinum Package (640AH, 400W Solar, 3000W Xantrex Inverter)
Truma water heater & AC

TV: 2024 Silverado 2500HD 6.6L 10-Speed Allison

Link to comment
Share on other sites

On 12/26/2023 at 6:11 PM, ScubaRx said:

The transfer switch (gen switch, if that is what you're referring to) does not come into play if plugging the generator into the side port. But, if you plug it in there and it passes power to the coach it validates what I said above, the transfer switch is bad.

I’m not sure what generator he’s using. Some have a separate switch/breaker for power output even if the engine is running.  Was just spitballing ideas, not really applicable now since he is getting power to the trailer. 
 

I agree that @DonnaDuane needs to plug the trailer in to shore power using the main side power cord.  If everything works then plug the generator in using the same cord.  If that works move to the front power input and see if that works.  The transfer switch could be failing or the new wire added might have caused a problem with how it functions.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...